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Overview 

CranePro 3D is an advanced parametric modeling software designed for 

engineers, planners, and lifting specialists to create, visualize, and analyze crane 

operations in a 3D environment. The software allows users to efficiently 

generate detailed crane models, simulate lifting scenarios, and optimize lift 

planning while ensuring safety and operational efficiency. 

 

Built to enhance the precision and accuracy of crane-related projects, CranePro 

3D integrates industry-standard lifting parameters, including crane charts, boom 

configurations, and load limits. This ensures that users can assess crane 

capabilities, avoid overloading, and improve decision-making during planning 

and execution phases. 

 

Important Note: While CranePro 3D provides valuable tools for lift planning, the 

final responsibility lies with the user. Engineers and operators must always verify 

lifting configurations against the official crane load charts and site conditions to 

ensure compliance with safety standards and manufacturer specifications. The 

software is intended to assist in decision-making but does not replace the need 

for professional judgment and thorough review. 

 

Whether for construction, heavy lifting, or industrial applications, CranePro 3D 

provides a reliable and user-friendly platform that streamlines crane selection, 

placement, and lifting procedures in compliance with engineering best practices.  

 

Key Features 

• Extensive Crane Library – Includes a growing database of parametric crane models 
with customizable configurations. 

• Parametric Design – Users can modify boom length, angles, and attachments 
dynamically based on specific project requirements. 
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• Load Chart Integration – Automatically applies load charts to ensure realistic and 
safe lifting capacities. 

• Lifting Simulation – Enables users to visualize lifting operations, assess stability, and 
optimize crane placement. 

• Reach and Boundary Analysis – Helps in determining maximum reach, load 
limitations, and working area constraints. 

• Integration with Engineering Software – Compatible with Autodesk for enhanced 
workflow efficiency. 

• Lift Planning Support – Facilitates the generation of lift plans, including rigging 
configurations and clearance studies. 

• Safety Compliance – Ensures lifting scenarios comply with engineering standards and 

safety guidelines. 

Purpose of This Manual 

This manual serves as a comprehensive guide to help you: 

1. Understand the core features and functionalities of CranePro 3D. 

2. Navigate the software interface with ease. 

3. Create high-quality models and drawings efficiently. 

4. Maximize the software's capabilities for enhanced proCraneivity. 

Whether you are a first-time user or an experienced professional, this manual is 

designed to equip you with the knowledge and skills to get the most out of 

CranePro 3D. 

Copyright, Licensing, and Disclaimer 

Copyright 

CranePro 3D software and its associated content, including but not limited to 

the software code, documentation, designs, and icons, are the exclusive 

intellectual property of [Ahmed Hegazy & SE CAD Solutions]. All rights are 

reserved. Unauthorized copying, distribution, or modification of the software or 

its components is strictly prohibited. 

 

Licensing 
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CranePro 3D is available under a cloud-based licensing model designed to 

provide flexibility to users based on their project timelines and needs. Licenses 

are offered in the following subscription durations: 

• 3-Year Subscription 

• 1-Year Subscription 

• 6-Month Subscription 

• 3-Month Subscription 

• 2-Month Subscription 

• 1-Month Subscription 

All licenses include access to software updates and technical support for the 

duration of the subscription. Renewal notifications will be provided before the 

subscription period ends. 

Disclaimer 

The CranePro 3D software is provided "as is," without warranty of any kind, 

either express or implied, including but not limited to the implied warranties of 

merchantability and fitness for a particular purpose. While every effort is made 

to ensure accuracy and reliability, [SE CAD Solutions] shall not be held liable for 

any direct, indirect, or consequential damages arising from the use or inability to 

use the software. 

It is the responsibility of the user to verify that the output from CranePro 3D 

meets project specifications and industry standards. 

For detailed terms and conditions, please refer to the End User License 

Agreement (EULA) included with the software package. 
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System Requirements 

CranePro 3D is designed to operate efficiently without demanding high-end 

hardware specifications. However, since CranePro 3D runs within the Autodesk 

Inventor environment, it is essential that your system meets the Autodesk 

Inventor system requirements for versions 2020 to 2026. 

Minimum System Requirements 

To ensure a smooth experience with CranePro 3D, your system should meet the 

following baseline requirements: 

• Operating System: 

Windows 10 (64-bit) or newer. 

• Processor: 

64-bit Intel® or AMD® multi-core processor with SSE2 support. 

• RAM: 

At least 8 GB (16 GB or more is recommended for complex projects). 

• Graphics: 

Microsoft® DirectX® 11 compliant graphics card with at least 2 GB of 

VRAM. 

• Storage: 

Minimum 40 GB of free space for Autodesk Inventor installation and 

CranePro 3D software files. 

• Internet: 

A stable internet connection is required for license activation, updates, and 

cloud features. 

• Software: 

Autodesk Inventor 2020, 2021, 2022, 2023, 2024, 2025, or 2026 must be 

installed on your system. 

Recommended System Requirements 

For optimal performance when working on large-scale projects: 
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• Processor: Intel® Core™ i7 or AMD Ryzen™ equivalent. 

• RAM: 32 GB or more. 

• Graphics: A high-performance GPU with 4 GB or more of VRAM, such as 

NVIDIA Quadro or AMD Radeon Pro series. 

• Storage: SSD with sufficient space for project files and backups. 

Additional Notes 

• Ensure your system is up-to-date with the latest Windows updates and 

drivers, particularly for graphics cards. 

• Autodesk Inventor’s official system requirements may vary slightly with 

version updates. Refer to Autodesk’s website for the most accurate and 

detailed specifications. 

By meeting these requirements, users can take full advantage of CranePro 3D's 

capabilities and ensure seamless integration with Autodesk Inventor. 

 

 

Installing on Your Computer 

This section provides a step-by-step guide to installing CranePro 3D software on 

your computer. Ensure your system meets the minimum system requirements 

before proceeding. 

Step 1: Download the Installation Package 

1. Visit the official SE CAD Solutions website or the download link provided in 

your purchase confirmation email. 

2. Download the CranePro 3D installation package compatible with your 

version of Autodesk Inventor (2020–2026). 

Step 2: Prepare for Installation 

1. Ensure Autodesk Inventor is installed and functional on your system. 

2. Close all running applications to avoid conflicts during installation. 
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3. Disable any antivirus software temporarily, as it might interfere with the 

installation process. 

Step 3: Run the Installer 

1. Locate the downloaded installation file (e.g., CranePro 3D.exe) and double-

click it to begin. 

2. Follow the on-screen instructions: 

o Select the installation directory (default is recommended). 

o Agree to the End User License Agreement (EULA). 

3. Click Install to begin the process. 

Step 4: Activate Your License 

1. Once installation is complete, run CranePro 3D from your desktop. 

2. The CranePro 3D Login window will appear. 

3. First-Time Users: 

o If this is your first time using CranePro 3D, you will need to register. 

o Click on the Register button and fill in all the required data, such as 

your name, email address, and company details. 

o Create a strong password and submit the form. 

o After registration, you will get 15 days as an evaluation period. 

4. Returning Users: 

o If you already have an account, simply log in using your email and 

password. 

Notes: 

• Contact us to activate your account (secadsolutions@gmail.com & 

contact@secadsolutions.com) 

• If you encounter any issues during activation, please contact technical 

support. 

mailto:secadsolutions@gmail.com
mailto:contact@secadsolutions.com
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Troubleshooting 

• If CranePro 3D does not running over Autodesk Inventor, ensure that the 

version of Inventor you are using is supported. 

• Contact technical support if activation fails or if you encounter installation 

errors. 

Uninstallation 

To remove CranePro 3D: 

1. Open the Control Panel in Windows. 

2. Navigate to Programs and Features. 

3. Select CranePro 3D and click Uninstall. 

4. Follow the prompts to complete the removal. 
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Terminology Clarification 

This section would explain frequently misunderstood or interchangeable terms 

used in the context of Crane and sheet metal design 

1. Lifting Chart for a Crane 

A Lifting Chart (or Load Chart) is a document provided by the crane manufacturer that 
defines the crane's lifting capacity under different configurations. It includes essential data 
such as maximum load limits, boom lengths, lifting angles, counterweight requirements, 
and operational restrictions. The lifting chart helps operators determine the safe working 
limits of the crane and ensures that lifting operations comply with safety standards. 

2. Boom Lifting Angle 

The Boom Lifting Angle refers to the angle between the crane’s boom and the horizontal 
ground level. This angle directly affects the lifting capacity and reach of the crane. A higher 
boom angle generally increases vertical lifting capability but reduces horizontal reach. The 
boom lifting angle is a crucial parameter in lift planning to ensure proper positioning and 
safe operation. 

3. Boom Lifting Radius 

The Boom Lifting Radius is the horizontal distance measured from the center of rotation of 
the crane (slewing center) to the center of the load being lifted. It is a key factor in 
determining the crane’s lifting capacity since the load-bearing capacity decreases as the 
radius increases. The boom radius is influenced by the boom length, angle, and extension of 
any additional jibs. 

4. Center of Gravity (CG) 

The Center of Gravity (CG) is the point at which the entire weight of an object is considered 
to be concentrated. For cranes, understanding the CG of both the crane itself and the load 
being lifted is critical for maintaining balance and stability. Improper weight distribution can 
lead to tipping or structural failure. In lifting operations, the CG helps determine the proper 
rigging configuration and ensures that the load remains stable throughout the lift. 
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Getting Started with CranePro 3D 

Welcome to CranePro 3D! This section will guide you through the initial steps to 

get up and running with the software, from installation to creating your first 3D 

model. 

1. Launching CranePro 3D 

After installing CranePro 3D and activating your license, you are ready to launch 

the software. Follow these steps to get started: 

• Locate CranePro 3D: Open CranePro 3D from your desktop shortcut or the 

Start menu. 

• Create a new Project: Give a name for your project and select path in your 

machine. 

• Initial Screen: Upon launching the software, the main interface will load, 

allowing you to begin working on cranes, trucks, and various accessories 

such as spreader beams, wires, shackles, and more. 

 

2. User Interface Overview 

The CranePro 3D user interface (UI) is designed to be intuitive and easy to 

navigate. Familiarizing yourself with the basic elements of the interface will help 

you get comfortable quickly. 

• Main Ribbon: The top toolbar contains icons representing different types 

of cranes, manlift, lifting wires and shackles. 

• Project Browser: On the left side, you'll find the project browser, which 

shows the components (Cranes) in your current project. 

• Workspace: The large central area is the Crane dimensions form with 

image to indicates the required data you should fill for your crane. 

 

3. Adding Components to Your Project 
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Once your project is set up, you can begin adding components to your design: 

• Step 1: Select a component type from the Main Ribbon, such as a Haulotte 

or LTM_1130-5.1. 

• Step 2: The properties for that component will appear in the Properties 

Palette. Adjust parameters like dimensions and color. 

• Step 3: Place the component in your 3D workspace over Autodesk inventor 

by clicking on build from the Project menu, once you did that the 3D 

model (Assembly of the Crane parts and assembly shall be generated). 

• Step 4: Continue adding other components as needed for your design. 

 

4. Modifying Components 

You can modify any component at any time using either of the following 

methods: 

 

Method 1: Using the Project Browser 

1. Select the component in the CranePro 3D tree (Project Browser). 

2. In the Properties Palette, adjust the dimensions, color, or other 

parameters as needed. 

3. Click on Build from the Project menu. Once executed, the 3D model (Crane 

Assembly) will be updated accordingly. 

Method 2: Using the iLogic Browser in Autodesk Inventor 

1. After creating the Crane Assembly in Autodesk Inventor, go to the View 

tab, open the User Interface, and enable the iLogic Browser. 

2. Drag and drop the iLogic Browser to your preferred location in the 

Inventor interface (e.g., left or right panel). 

3. Select the Forms tab within the iLogic Browser. 

4. Open the Crane Form and make the necessary edits to your assembly. 
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5. Saving Your Work 

It’s always a good idea to save your work regularly: 

• Step 1: Click File > Save to save your project for the first time. 

• Step 2: After saving, click File > Save to save any subsequent changes. 

 

6. Using Help and Support 

If you ever need assistance: 

• In-Software Help: Access the built-in help system by clicking the File > 

Manuel. This will open the Instruction Manuel for detailed instructions on 

all CranePro 3D features. 

• Online Tutorials: Visit our YouTube channel for more resources, including 

Tutorials. 
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Main Cranes and Accessories in CranePro 3D 

CranePro 3D software provides users with a wide range of 3D parametric models for cranes 
and accessories, enabling engineers and planners to design and simulate lifting operations 
with precision and flexibility. Below is a list of the main cranes and accessories available in 
the software: 

 

1. Standard Accessories 

CranePro 3D includes essential accessories commonly used in lifting operations. These 
accessories can be inserted and configured within your project to reflect real-world safety 
and rigging setups. 

• Safety Cones: Used to mark safe zones or restricted areas around lifting operations. 
• Safety Steel Barriers: Installed to secure the crane working area and prevent 

unauthorized access. 
• Spreader Beams: Rigging tools used to distribute loads evenly during lifting. 
• Wires with Shackles: Predefined rigging elements used to connect loads to the crane 

hook or spreader beam. 

 

2. Built-in Crane Models 

These cranes are preloaded in the software and ready to use in your projects: 

All Terrain and Rough Terrain Cranes 

• ATF-70G-4 – All Terrain Crane 
• GR-130EX-2 – Rough Terrain Crane 
• GR-150XL-2 – Rough Terrain Crane 
• GR-300EX-3 – Rough Terrain Crane 
• GR-350XL-3 – Rough Terrain Crane 
• GR-1450EX-3 – Rough Terrain Crane 
• GR-1600XL-3 – Rough Terrain Crane 

Truck Cranes 

• LTC 1050-3.1 – Compact Truck Crane with high maneuverability 
• LTM 1130-5.1 – Five-axle Truck Crane with long boom 
• LTM_1050-3. 1 – three-axle Truck Crane with long boom  
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• LTM_1070-4. 1 – Four-axle Truck Crane with long boom  
• LTM_1200-5. 1 – Five-axle Truck Crane with long boom  
• LTM_1300-6. 2 – Six -axle Truck Crane with long boom 
• LTM 1250-6.1 – Six-axle Truck Crane offering high lifting capacity 

Crawler Cranes 

• LTR 1100 – Telescopic Boom Crawler Crane 

 

3. Other Equipment 

• Haulotte – Aerial work platform for personnel and light tools 

 

4. Additional Cranes (Downloadable) 

Users can extend their library by downloading more crane models through the “Download 
Cranes” button within the software. Currently available downloads include: 

• GR-500EX-2 
• GR-500EXL-3 
• GR-500EXS-3 

 

5. Trucks 

A variety of generic truck models are also included in the software for planning 
transportation logistics and site access. 

 

Use Cases in CranePro 3D 

CranePro 3D enables engineers, construction planners, and rigging specialists to simulate 
real-world lifting scenarios with high accuracy. Users can: 

• Plan Complex Lifts – Define crane configurations, boom lengths, and lifting angles. 
• Visualize Load Charts – Ensure that lifting capacities align with manufacturer 

specifications. 
• Optimize Rigging Configurations – Identify safe load attachment points and angles. 
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• Simulate Site Constraints – Account for ground conditions, obstacles, and clearance 
requirements. 

• Enhance Safety & Compliance – Reduce the risk of exceeding operational limits. 

Each crane model in CranePro 3D is built with parametric design principles, ensuring that 
users can modify and adapt crane configurations based on their project needs. 

 

7. Troubleshooting Common Errors 

In this part of the instruction manual, we will discuss some of the common 

errors and how to troubleshoot them. 

• Language Configuration Issues: 

If you face an issue during project creation or when the build completes 

without any action in Autodesk Inventor, it indicates that the system 

language must be set to English (United States). 

 
Kindly open start button and wright “Language Setting”  
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1. Open the Start Menu and type Language Settings. 

2. Change the display language to English (United States). 

3. Restart your computer. 

4. Launch SEG again and retry. 

 

 

• Symbol Display and Formatting Error 

Before lunching SEG you will need to be sure from the Symbol formatting. 

 

1. Modify the Regional Settings: 

o Open Control Panel > Region 

o Under the Formats tab, click Additional settings... 

o Ensure the Decimal Symbol is set to "." (dot) instead of "," (comma) 

o Apply the changes and restart your computer 
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• Migration Option - Saving form (for each parts, assemblies and drawings) 

appearance. 

If you receive a save confirmation message for each file type—Part, 

Assembly, or Drawing—similar to the message shown in the image, this 

indicates that Autodesk Inventor’s Migration setting is preventing 

automatic updates. 

 

 
 

 
 

To resolve this issue, you need to adjust the Migration Option. 

Please follow the steps below: 
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1. Go to the Tools tab. 

2. Click Application Options. 

3. Open the Save tab. 

4. Find the Migration setting. 

5. Change its value from No to Yes. 

6. Apply to Save the changes.  

This will allow Inventor to automatically update and save migrated files 

without prompting you for each item. 
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• Whitelist and Server Synchronization Error 

If you receive a message stating that you need to be connected to the 

internet while you are already online, it means SEG is being blocked from 

reaching the server. 

To resolve this issue: 

 

1. Whitelist the following URLs and IP addresses in your firewall/antivirus 

or network settings: 

o https://license.secadsolutions.com/Account/Login 

o http://secadsolution.com/Account/Login 

o 154.41.209.210 

o 208.98.35.168 

2. Retry launching SEG. 

o If the issue persists, it indicates that something (most likely your 

antivirus software) is still blocking SEG from sending requests to 

our servers. 

3. Check with antivirus software: 

o Temporarily disable your antivirus and try running SEG. 

o If SEG works correctly, then re-enable your antivirus and ask your 

IT team to whitelist the above URLs and IP addresses within the 

antivirus configuration. 

     

If you still facing the same message 

please navigate to the following path and share the updated 

cp_application.log file with secadsolutions@gmail.com: 

C:\Users\[Your Username]\AppData\Local 

This will help us verify the update and assist you further if needed. 
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Visual Reference: 
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Accessories

 

 

 

ATF-70G-4 
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Equipment 

 

 

 

GR-130EX-2 
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GR-150XL-2 

 

 

 

GR-300EX-3 
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GR-350XL-3 

 

 

 

GR-1600XL-3 
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GR-1450EX-3

 

 

GR-500EX-2
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GR-500EXL-3

 

 

GR-500EXS-3

 

 

 



CranePro 3D (V2) 
 

30 | P a g e  
 

Manlift 

 

 

Forklift 
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LTC_1050-3.1 

 

 

LTM_1050-3.1 
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LTM_1130-5.1 

 

 

 

LTM_1250-6.1 
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LTR_1100 

 

Downloaded Items 
LTM_1090-4.2

 



CranePro 3D (V2) 
 

34 | P a g e  
 

LTM_1450-8.1

 

 

 

Site Layouts
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SPMT

 

Truck 
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LTM_1070-4.2 

 

LTM_1200-5.1 
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LTM_1300-6.2 

 

 

Additional items are available in the library, which will continue to be updated 

regularly. Please check back periodically for the latest additions. 
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Examples 

 

Haulotte (HA32PX) 

Step 1: Create a new Project 

 

 

Step 2: Defined the project Name & Directory. 

Step 3: Click create button to create the project folder and needed files. 

Step 4: From the elements Reborn, select Haulotte type. 

Step 5: From family (HA32PX) 

Step 6: Give a name for the Crane (Part Name), and click Add button. 
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Step 7: Defined the Bend dimensions. 
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Defined Dimensions as below 

 

Step 8: From Project tab select Build to create all items inside CranePro 3D tree 

 

The same result you can make it for a single node in case of selecting the node 

from CranePro 3D tree and right click to get the shortcut menu, and select Build 

to build the selected node. 
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Step 9: After Creating the 3D model of the Crane and the 2D Drawing, you can 

open both separately from the node shortcut menu. 
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Step 10: You can Export the 3D model from the shortcut menu. 

 

 

 

Select the exporting directory 

The following images for the available formats for Assembly that you can 

export 
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LTM_1130-5.1 (LTM_1130-5.1-TypeA) 

Step 1: From the elements Reborn, select LTM_1130-5.1. 

Step 2: From family (LTM_1130-5.1-TypeA) 

Step 3: Give a name for the Crane (Part Name), and click Add button. 

 

 

Step 4: Defined the LTM_1130-5.1-TypeA dimensions. 
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Defined Dimensions as below 

 

Step 5: From Project tab select Build to create all items inside CranePro 3D tree 

 

The same result you can make it for a single node in case of selecting the node 

from CranePro 3D tree and right click to get the shortcut menu, and select Build 

to build the selected node. 
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Step 6: You can Export the 3D model from the shortcut menu. 

 

 

 

Select the exporting directory 

The following images for the available formats for Assembly that you can 

export 
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Application Themes 

Light, Blue and Midnight Themes are available, you can choose between them. 
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Application Font Size 

Small, Medium and Large font Sizes are available, you can choose between 

them. 

(8, 10, 12) 
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Abort 

The Abort feature allows you to interrupt the processing of multiple Crane models 

running in Autodesk Inventor. By using the Abort command, you can stop the 

operation after the current Crane model and its associated drawing are completed, 

giving you control over the workflow without losing progress on the active task. 
 

 

Reset 

The Reset feature enables users to clear the entire project by deleting all associated 

Autodesk Inventor assemblies, parts, and drawings. This function provides a clean 

slate, allowing users to restart the project from the beginning without retaining any 

previous data. Use this tool cautiously, as it will permanently remove all existing 

project files. 
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Download Cranes 

The Download Cranes feature allows users to download newly added support types 

that have been uploaded to our cloud server. This ensures that your CranePro 3D 

software always stays up to date with the latest support models and configurations. 

 

 
 

 

Service Health 
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The Service Health feature allows users to monitor the connection status between 
CranePro 3D and its servers. This ensures that the application is running smoothly and can 
access the necessary online services. 

Currently, two servers are available: 

• Primary Server – displayed on the first line. 
• Secondary Server – displayed on the second line. 

For each server, the system displays the response time, which indicates how long it takes to 
establish the connection. A lower response time reflects a faster and healthier connection. 

By regularly checking the Service Health window, users can quickly identify if there are any 
connectivity issues and determine whether the system is operating on the primary or 
backup server. 

 

 
 

 
 

Create Empty Drawing 
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The Create Empty Drawing feature allows users to generate a blank CranePro 3D drawing 
that can be used during Lifting Plan preparation. You can create and add any number of 
empty drawings to your project. 

To create an empty drawing: 

1. Open the Project tab. 
2. Select the Create Empty Drawing option. 
3. A form will appear where you can: 

o Enter a name for the drawing. 
o Choose a save path for the file. The default path is set to the project folder. 

4. Click Save to generate the drawing with the specified name in the selected location. 

This feature makes it easy to prepare customized drawing files, ready for adding crane 
configurations, lifting details, and annotations as required. 

 

 
 

 


